import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(skip-if-active=\")([^\"]+)(\")";
final String string = "<script skip-if-active=\"facebook-for-woocommerce/facebook-for-woocomerce.php\">\n"
+ " !(function (f, b, e, v, n, t, s) {\n"
+ " if (f.fbq) return;\n"
+ " n = f.fbq = function () {\n"
+ " n.callMethod ? n.callMethod.apply(n, arguments) : n.queue.push(arguments);\n"
+ " };\n"
+ " if (!f._fbq) f._fbq = n;\n"
+ " n.push = n;\n"
+ " n.loaded = !0;\n"
+ " n.version = \"2.0\";\n"
+ " n.queue = [];\n"
+ " t = b.createElement(e);\n"
+ " t.async = !0;\n"
+ " t.src = v;\n"
+ " s = b.getElementsByTagName(e)[0];\n"
+ " s.parentNode.insertBefore(t, s);\n"
+ " })(window, document, \"script\", \"https://connect.facebook.net/de_DE/fbevents.js\");\n"
+ " fbq(\"init\", \"{{fbPixelId}}\");\n"
+ " fbq(\"track\", \"PageView\");\n"
+ "</script>\n"
+ "<noscript><img height=\"1\" width=\"1\" alt=\"\" style=\"display: none;\" src=\"https://www.facebook.com/tr?id={{fbPixelId}}&ev=PageView&noscript=1\" /></noscript>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}