const regex = /(skip-if-active=")([^"]+)(")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(skip-if-active=")([^"]+)(")', 'gm')
const str = `<script skip-if-active="facebook-for-woocommerce/facebook-for-woocomerce.php">
!(function (f, b, e, v, n, t, s) {
if (f.fbq) return;
n = f.fbq = function () {
n.callMethod ? n.callMethod.apply(n, arguments) : n.queue.push(arguments);
};
if (!f._fbq) f._fbq = n;
n.push = n;
n.loaded = !0;
n.version = "2.0";
n.queue = [];
t = b.createElement(e);
t.async = !0;
t.src = v;
s = b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t, s);
})(window, document, "script", "https://connect.facebook.net/de_DE/fbevents.js");
fbq("init", "{{fbPixelId}}");
fbq("track", "PageView");
</script>
<noscript><img height="1" width="1" alt="" style="display: none;" src="https://www.facebook.com/tr?id={{fbPixelId}}&ev=PageView&noscript=1" /></noscript>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);