package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^-]+)\/$`)
var str = `dossier/mon-url-AZ19/
dossier/mon-url-AZ&19/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}