$re = '/([^-]+)\/$/m';
$str = 'dossier/mon-url-AZ19/
dossier/mon-url-AZ&19/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);