const regex = /(?<=^|\s)(?<Day>0[1-9]|1[0-9]|2[0-9]|3[0-1]|[1-9])(?:st|nd|rd|th)?(?:\/| |-|\.)(?<Month>0[1-9]|1[0-2]|[1-9]|Jan|January|Feb|February|Mar|March|Apr|April|May|Jun|June|Jul|July|Aug|August|Sep|September|Oct|October|Nov|November|Dec|December)(?:-|\/| |\.)(?<Year>(?:[1-2]\d)?(?:\d\d))(?=\s)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)(?<Day>0[1-9]|1[0-9]|2[0-9]|3[0-1]|[1-9])(?:st|nd|rd|th)?(?:\\\/| |-|\\.)(?<Month>0[1-9]|1[0-2]|[1-9]|Jan|January|Feb|February|Mar|March|Apr|April|May|Jun|June|Jul|July|Aug|August|Sep|September|Oct|October|Nov|November|Dec|December)(?:-|\\\/| |\\.)(?<Year>(?:[1-2]\\d)?(?:\\d\\d))(?=\\s)', 'gmi')
const str = `1/2/03
01/9/2013
01 02 2018
10.02.2011
10th JAN 2018
10th Jan 18
01st January 2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}