import Foundation
let pattern = #"(?<=^|\s)(?<Day>0[1-9]|1[0-9]|2[0-9]|3[0-1]|[1-9])(?:st|nd|rd|th)?(?:\/| |-|\.)(?<Month>0[1-9]|1[0-2]|[1-9]|Jan|January|Feb|February|Mar|March|Apr|April|May|Jun|June|Jul|July|Aug|August|Sep|September|Oct|October|Nov|November|Dec|December)(?:-|\/| |\.)(?<Year>(?:[1-2]\d)?(?:\d\d))(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
1/2/03
01/9/2013
01 02 2018
10.02.2011
10th JAN 2018
10th Jan 18
01st January 2018
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)