package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bregulator(?:y|ies|s)\b`)
var str = `“regulatory†“regulatories†(begins “regulators†/ regulatorial`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}