re = /\bregulator(?:y|ies|s)\b/
str = '“regulatory†“regulatories†(begins “regulators†/ regulatorial'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end