$re = '/([^?.]+[?.])(?:\s|$)/';
$str = 'This is sentence 1. This is sentence 2? This is sentence 3.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);