re = /([^?.]+[?.])(?:\s|$)/
str = 'This is sentence 1. This is sentence 2? This is sentence 3.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end