#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\{\s*(?<key1>[^=\s*]+)\s*=\s*(?<value1>\([^)]+\))\s*(?:,\s*(?<key2>[^=\s*]+)\s*=\s*(?<value2>\([^)]+\))\s*)?\}"
Local $sString = "The string I receive is something like this format, representing the changes: {xRate=(250.0, 260.0), yValue=(1.51, 1.54)}." & @CRLF & _
"" & @CRLF & _
"I would like to get something like [['xRate', '(250.0, 260.0)'],['yValue', '(1.51, 1.54)']] or at least have a regex to work since I can't figure it out." & @CRLF & _
"" & @CRLF & _
"I tried /,*\s*(.*)=\s*(.*)/ but it creates group1 as test=(23, 34), var and group2 as (true , false) in test=(23, 34), var=(true , false), for example." & @CRLF & _
"" & @CRLF & _
"{xRate=(250.0, 260.0) , yValue =(1.51, 1.54)} ... { xRate = (250.0, 260.0) }" & @CRLF & _
"... { yValue=(1.51, 1.54) } ... { xRate = ( 250.0 , 260.0), yValue=(1.51, 1.54) }" & @CRLF & _
""
Local $sSubst = "[['$1', '$2'], ['$3', '$4']]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)