using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s*(?<key1>[^=\s*]+)\s*=\s*(?<value1>\([^)]+\))\s*(?:,\s*(?<key2>[^=\s*]+)\s*=\s*(?<value2>\([^)]+\))\s*)?\}";
string substitution = @"[['$1', '$2'], ['$3', '$4']]";
string input = @"The string I receive is something like this format, representing the changes: {xRate=(250.0, 260.0), yValue=(1.51, 1.54)}.
I would like to get something like [['xRate', '(250.0, 260.0)'],['yValue', '(1.51, 1.54)']] or at least have a regex to work since I can't figure it out.
I tried /,*\s*(.*)=\s*(.*)/ but it creates group1 as test=(23, 34), var and group2 as (true , false) in test=(23, 34), var=(true , false), for example.
{xRate=(250.0, 260.0) , yValue =(1.51, 1.54)} ... { xRate = (250.0, 260.0) }
... { yValue=(1.51, 1.54) } ... { xRate = ( 250.0 , 260.0), yValue=(1.51, 1.54) }
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}