using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<sequenceFlag>[{,])\s*(?<key>\w+)\s*=\s*(?<value>\([^)]+\))\s*(?<terminatingFlag>\}?)";
string substitution = @"['$2', '$3'], ";
string input = @"{xRate=(250.0, 260.0) , yValue =(1.51, 1.54)} ... { xRate = (250.0, 260.0) }
... { yValue=(1.51, 1.54) } ... { xRate = ( 250.0 , 260.0), yValue=(1.51, 1.54) }
{ xRate = ( 250.0, 260.0 ) ,yValue=(1.51,1.54), zItem =( foo, bar,baz) } ... {xRate=(250.0,260.0)}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}