use strict;
my $str = '{xRate=(250.0, 260.0) , yValue =(1.51, 1.54)} ... { xRate = (250.0, 260.0) }
... { yValue=(1.51, 1.54) } ... { xRate = ( 250.0 , 260.0), yValue=(1.51, 1.54) }
{ xRate = ( 250.0, 260.0 ) ,yValue=(1.51,1.54), zItem =( foo, bar,baz) } ... {xRate=(250.0,260.0)}
';
my $regex = qr/(?<sequenceFlag>[{,])\s*(?<key>\w+)\s*=\s*(?<value>\([^)]+\))\s*(?<terminatingFlag>\}?)/p;
my $subst = '[\'$2\', \'$3\'], ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";