package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[./])(0+)`)
var str = `001234
1234
00AbcD
001234.1234
001234.000002
001234/000002`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}