$re = '/(^|[./])(0+)/m';
$str = '001234
1234
00AbcD
001234.1234
001234.000002
001234/000002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);