const regex = /^[\S\s]*?^([^][]*=)\[\[.*\]\]\K\]\R\1\[(.*)\]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\S\\s]*?^([^][]*=)\\[\\[.*\\]\\]\\K\\]\\R\\1\\[(.*)\\]$', 'gm')
const str = `3 Forest Park Trolley - SOUTH=[[DEBALIVIERE GARAGE,[38.652722,-90.285656]]]
3 Forest Park Trolley - SOUTH=[[PERSHING @ DEBALIVIERE EB,[38.648548,-90.284849]]]
3 Forest Park Trolley - SOUTH=[[PERSHING @ CLARA EB,[38.648346,-90.282791]]]
3 Forest Park Trolley - SOUTH=[[PERSHING @ BELT EB,[38.647911,-90.278559]]]
3 Forest Park Trolley - SOUTH=[[5370 PERSHING EB,[38.64772,-90.276634]]]
3 Forest Park Trolley - SOUTH=[[PERSHING @ UNION EB,[38.647512,-90.274466]]]
3 Forest Park Trolley - SOUTH=[[FOREST PARK VISITORS CENTER WB,[38.643494,-90.283964]]]
3 Forest Park Trolley - SOUTH=[[LAGOON @ GRAND BASIN WB,[38.64356,-90.291827]]]
3 Forest Park Trolley - SOUTH=[[FINE ARTS @ ART MUSEUM SB,[38.639576,-90.294284]]]
3 Forest Park Trolley - SOUTH=[[FINE ARTS @ ST LOUIS ZOO SB,[38.636939,-90.29116]]]
3 Forest Park Trolley - SOUTH=[[FINE ARTS @ ST LOUIS ZOO SB,[38.636939,-90.29116]]]
3 Forest Park Trolley - SOUTH=[[GOVERNMENT @ BOAT HOUSE EB,[38.639304,-90.284422]]]
3 Forest Park Trolley - SOUTH=[[MCKINLEY @ MUNY THEATRE SB,[38.640333,-90.282175]]]
3 Forest Park Trolley - SOUTH=[[UNION @ MUNY PARKING LOT EB,[38.636305,-90.279704]]]
3 Forest Park Trolley - SOUTH=[[WELLS @ STEINBERG SKATING RINK EB,[38.638102,-90.27106]]]
3 Forest Park Trolley - SOUTH=[[ST LOUIS SCIENCE CENTER LOOP,[38.631607,-90.2708]]]
3 Forest Park Trolley - NORTH=[[ST LOUIS SCIENCE CENTER LOOP,[38.631607,-90.2708]]]
3 Forest Park Trolley - NORTH=[[WELLS @ STEINBERG SKATING RINK WB,[38.638219,-90.271291]]]
3 Forest Park Trolley - NORTH=[[UNION @ MUNY PARKING LOT WB,[38.636457,-90.279796]]]
3 Forest Park Trolley - NORTH=[[CONCOURSE @ WORLDS FAIR PAVILION WB,[38.636589,-90.284272]]]
3 Forest Park Trolley - NORTH=[[FINE ARTS @ ST LOUIS ZOO NB,[38.63707,-90.29103]]]
3 Forest Park Trolley - NORTH=[[FINE ARTS @ ART MUSEUM NB,[38.639685,-90.294058]]]
3 Forest Park Trolley - NORTH=[[LAGOON @ GRAND BASIN EB,[38.643417,-90.29192]]]
3 Forest Park Trolley - NORTH=[[FOREST PARK VISITORS CENTER EB,[38.643343,-90.283906]]]
3 Forest Park Trolley - NORTH=[[FINE ARTS @ ST LOUIS ZOO SB,[38.636939,-90.29116]]]
3 Forest Park Trolley - NORTH=[[GOVERNMENT @ BOAT HOUSE EB,[38.639304,-90.284422]]]
3 Forest Park Trolley - NORTH=[[PERSHING @ UNION WB,[38.647683,-90.274552]]]
3 Forest Park Trolley - NORTH=[[5375 PERSHING WB,[38.647901,-90.276743]]]
3 Forest Park Trolley - NORTH=[[PERSHING @ BELT WB,[38.648083,-90.278634]]]
3 Forest Park Trolley - NORTH=[[PERSHING @ CLARA WB,[38.648491,-90.282634]]]
3 Forest Park Trolley - NORTH=[[PERSHING @ DEBALIVIERE WB,[38.648726,-90.285022]]]
3 Forest Park Trolley - NORTH=[[DEBALIVIERE GARAGE,[38.652722,-90.285656]]]`;
const subst = `, \2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);