import re
regex = re.compile(r"^[\S\s]*?^([^][]*=)\[\[.*\]\]\K\]\R\1\[(.*)\]$", flags=re.MULTILINE)
test_str = ("3 Forest Park Trolley - SOUTH=[[DEBALIVIERE GARAGE,[38.652722,-90.285656]]]\n"
"3 Forest Park Trolley - SOUTH=[[PERSHING @ DEBALIVIERE EB,[38.648548,-90.284849]]]\n"
"3 Forest Park Trolley - SOUTH=[[PERSHING @ CLARA EB,[38.648346,-90.282791]]]\n"
"3 Forest Park Trolley - SOUTH=[[PERSHING @ BELT EB,[38.647911,-90.278559]]]\n"
"3 Forest Park Trolley - SOUTH=[[5370 PERSHING EB,[38.64772,-90.276634]]]\n"
"3 Forest Park Trolley - SOUTH=[[PERSHING @ UNION EB,[38.647512,-90.274466]]]\n"
"3 Forest Park Trolley - SOUTH=[[FOREST PARK VISITORS CENTER WB,[38.643494,-90.283964]]]\n"
"3 Forest Park Trolley - SOUTH=[[LAGOON @ GRAND BASIN WB,[38.64356,-90.291827]]]\n"
"3 Forest Park Trolley - SOUTH=[[FINE ARTS @ ART MUSEUM SB,[38.639576,-90.294284]]]\n"
"3 Forest Park Trolley - SOUTH=[[FINE ARTS @ ST LOUIS ZOO SB,[38.636939,-90.29116]]]\n"
"3 Forest Park Trolley - SOUTH=[[FINE ARTS @ ST LOUIS ZOO SB,[38.636939,-90.29116]]]\n"
"3 Forest Park Trolley - SOUTH=[[GOVERNMENT @ BOAT HOUSE EB,[38.639304,-90.284422]]]\n"
"3 Forest Park Trolley - SOUTH=[[MCKINLEY @ MUNY THEATRE SB,[38.640333,-90.282175]]]\n"
"3 Forest Park Trolley - SOUTH=[[UNION @ MUNY PARKING LOT EB,[38.636305,-90.279704]]]\n"
"3 Forest Park Trolley - SOUTH=[[WELLS @ STEINBERG SKATING RINK EB,[38.638102,-90.27106]]]\n"
"3 Forest Park Trolley - SOUTH=[[ST LOUIS SCIENCE CENTER LOOP,[38.631607,-90.2708]]]\n"
"3 Forest Park Trolley - NORTH=[[ST LOUIS SCIENCE CENTER LOOP,[38.631607,-90.2708]]]\n"
"3 Forest Park Trolley - NORTH=[[WELLS @ STEINBERG SKATING RINK WB,[38.638219,-90.271291]]]\n"
"3 Forest Park Trolley - NORTH=[[UNION @ MUNY PARKING LOT WB,[38.636457,-90.279796]]]\n"
"3 Forest Park Trolley - NORTH=[[CONCOURSE @ WORLDS FAIR PAVILION WB,[38.636589,-90.284272]]]\n"
"3 Forest Park Trolley - NORTH=[[FINE ARTS @ ST LOUIS ZOO NB,[38.63707,-90.29103]]]\n"
"3 Forest Park Trolley - NORTH=[[FINE ARTS @ ART MUSEUM NB,[38.639685,-90.294058]]]\n"
"3 Forest Park Trolley - NORTH=[[LAGOON @ GRAND BASIN EB,[38.643417,-90.29192]]]\n"
"3 Forest Park Trolley - NORTH=[[FOREST PARK VISITORS CENTER EB,[38.643343,-90.283906]]]\n"
"3 Forest Park Trolley - NORTH=[[FINE ARTS @ ST LOUIS ZOO SB,[38.636939,-90.29116]]]\n"
"3 Forest Park Trolley - NORTH=[[GOVERNMENT @ BOAT HOUSE EB,[38.639304,-90.284422]]]\n"
"3 Forest Park Trolley - NORTH=[[PERSHING @ UNION WB,[38.647683,-90.274552]]]\n"
"3 Forest Park Trolley - NORTH=[[5375 PERSHING WB,[38.647901,-90.276743]]]\n"
"3 Forest Park Trolley - NORTH=[[PERSHING @ BELT WB,[38.648083,-90.278634]]]\n"
"3 Forest Park Trolley - NORTH=[[PERSHING @ CLARA WB,[38.648491,-90.282634]]]\n"
"3 Forest Park Trolley - NORTH=[[PERSHING @ DEBALIVIERE WB,[38.648726,-90.285022]]]\n"
"3 Forest Park Trolley - NORTH=[[DEBALIVIERE GARAGE,[38.652722,-90.285656]]]")
subst = ", \\2]"
result = regex.sub(subst, test_str)
if result:
print(result)