package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{7}`)
var str = `بانک ملي
خريد
ايرانسل
مبلغ 392,400
رمز 7767701`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}