$re = '/\d{7}/m';
$str = 'بانک ملي
خريد
ايرانسل
مبلغ 392,400
رمز 7767701';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);