import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=\\\"\\\"pinyin\\\"\\\">(.*?)<script>(?:(?!<script>).)*";
final String string = "<br>\n"
+ "<span class=\"\"b\"\">拼音:</span><span class=\"\"pinyin\"\">xī<script>Setduyin('Duyin/xi1')</script></span> <span class=\"\"b\"\">注音:</span><span class=\"\"pinyin\"\">ㄒㄧ<script>Setduyin('Duyin/xi1')</script></span><br>\n"
+ "<span class=\"\"b\"\">简体部首:</span>丨 <span class=\"\"b\"\">部首笔画:</span>1 <span class=\"\"b\"\">总笔画:</span>8<br><span class=\"\"b\"\">ç¹ä½“部首:</span>åœã€€<span class=\"\"b\"\">部首笔画:</span>2 <span class=\"\"b\"\">总笔画:</span>8<br><span class=\"\"b\"\">康熙å—典笔画</span>( å¥:8ï¼› )";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}