# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"class=\"\"pinyin\"\">(.*?)<script>(?:(?!<script>).)*"
test_str = ("<br>\n"
"<span class=\"\"b\"\">拼音:</span><span class=\"\"pinyin\"\">xī<script>Setduyin('Duyin/xi1')</script></span> <span class=\"\"b\"\">注音:</span><span class=\"\"pinyin\"\">ㄒㄧ<script>Setduyin('Duyin/xi1')</script></span><br>\n"
"<span class=\"\"b\"\">简体部首:</span>丨 <span class=\"\"b\"\">部首笔画:</span>1 <span class=\"\"b\"\">总笔画:</span>8<br><span class=\"\"b\"\">ç¹ä½“部首:</span>åœã€€<span class=\"\"b\"\">部首笔画:</span>2 <span class=\"\"b\"\">总笔画:</span>8<br><span class=\"\"b\"\">康熙å—典笔画</span>( å¥:8ï¼› )")
subst = "-"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.