import re
regex = re.compile(r"\{((\r?\n)*.+?(\r?\n)*)\}", flags=re.MULTILINE)
test_str = ("Int function(char c) {\n"
" Int a = 0;\n"
"}\n\n"
"Int function(char c) {\n"
" Int a = 0;\n"
" Int a = 0;\n\n"
"}\n\n"
"Int function(char c) { Int a = 0;}\n\n"
"Int function(char c) {\n"
" Int function(char c) { Int a = 0; }\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")