using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Purified)(\s?)(\w+)(\s?)(dust)";
string input = @"Purified copper ore
Purified copper dust
Tiny copper dust
Copper dust
Small copper dust";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}