re = /^(Purified)(\s?)(\w+)(\s?)(dust)/m
str = 'Purified copper ore
Purified copper dust
Tiny copper dust
Copper dust
Small copper dust'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end