package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img\s+src="(.*?)"\s+width="(.*?)"\s+height="(.*?)">`)
var str = `<img src="myurl.jpg" width="12" height="32">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}