$re = '/(?><img\s+)src="(.*?)"|width="(.*?)"|height="(.*?)">/i';
$str = '<img src="myurl.jpg" width="12" height="32">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);