re = /(?><img\s+)src="(.*?)"|width="(.*?)"|height="(.*?)">/i
str = '<img src="myurl.jpg" width="12" height="32">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end