$re = '~(?:^https?:[/]{2}[^/]*google.*?[/].*\b[$+#&]q=|\G)[$+#&]*(\w+)~m';
$str = 'https://www.google.nl/search?q=five+fingers&ie=utf-8&oe=utf-8&gws_rd=cr,ssl&ei=kERoVbmMO6fp7AaGioCYAw#safe=off&q=five+short+fingers+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);