re = /(?:^https?:[\/]{2}[^\/]*google.*?[\/].*\b[$+#&]q=|\G)[$+#&]*(\w+)/m
str = 'https://www.google.nl/search?q=five+fingers&ie=utf-8&oe=utf-8&gws_rd=cr,ssl&ei=kERoVbmMO6fp7AaGioCYAw#safe=off&q=five+short+fingers+
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end