#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?=LOREM :).+?(?:(?=LOREM :))"
Local $sString = "LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"LOREM : 10505050" & @CRLF & _
"IPSUM : 1050051051084" & @CRLF & _
"DOLOR : 2620620620652" & @CRLF & _
"AMETI : 54084840540540" & @CRLF & _
"qwe asd qwmiowej aosidjiqwjeapsld" & @CRLF & _
"qweqwpoekedj qpodk qpok dpdok qw" & @CRLF & _
"ea sdpokq w pow dekaspdok qwpoke asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")