# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=LOREM :).+?(?:(?=LOREM :))"
test_str = ("LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"LOREM : 10505050\n"
"IPSUM : 1050051051084\n"
"DOLOR : 2620620620652\n"
"AMETI : 54084840540540\n"
"qwe asd qwmiowej aosidjiqwjeapsld\n"
"qweqwpoekedj qpodk qpok dpdok qw\n"
"ea sdpokq w pow dekaspdok qwpoke asd")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.