#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\B(\?\?|\?)|\B(\!\!|\!)|\B(\[\])|\b(RWC)|\b(TODO))[:;.,-]?\d*($|\s.*$|\(.*$)"
Local $sString = "# Oh yeah, good luck with that." & @CRLF & _
"?? Can I use the gun?" & @CRLF & _
"" & @CRLF & _
"Enough about your promiscuous mother, Hermes! We have bigger problems. " & @CRLF & _
"" & @CRLF & _
"!!- Guards! Bring me the forms I need to fill out to have her taken away! " & @CRLF & _
"" & @CRLF & _
"TODO Shinier than yours, meatbag. " & @CRLF & _
"" & @CRLF & _
"- Wow, you got that off the Internet? " & @CRLF & _
"- In my day, the Internet was only used to download pornography." & @CRLF & _
"" & @CRLF & _
"Would you censor the Venus de Venus just because you can see her spewers? " & @CRLF & _
"! No argument here. " & @CRLF & _
"" & @CRLF & _
"RWC: Oh no! The professor will hit me! " & @CRLF & _
"[] But if Zoidberg 'fixes' it… then perhaps gifts! " & @CRLF & _
"" & @CRLF & _
"I was all of history's great robot actors - Acting Unit 0. 8; Thespomat; David Duchovny!" & @CRLF & _
"" & @CRLF & _
"[] Five hours? Aw, man! Couldn't you just get me the death penalty?" & @CRLF & _
"" & @CRLF & _
"When I was first asked to make a film about my nephew, Hubert Farnsworth, I thought "Why should I?" Then later, Leela made the film. But if I did make it, you can bet there would have been more topless women on motorcycles. Roll film! Um, is this the boring, peaceful kind of taking to the streets?" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")