# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\B(\?\?|\?)|\B(\!\!|\!)|\B(\[\])|\b(RWC)|\b(TODO))[:;.,-]?\d*($|\s.*$|\(.*$)"
test_str = ("# Oh yeah, good luck with that.\n"
"?? Can I use the gun?\n\n"
"Enough about your promiscuous mother, Hermes! We have bigger problems. \n\n"
"!!- Guards! Bring me the forms I need to fill out to have her taken away! \n\n"
"TODO Shinier than yours, meatbag. \n\n"
"- Wow, you got that off the Internet? \n"
"- In my day, the Internet was only used to download pornography.\n\n"
"Would you censor the Venus de Venus just because you can see her spewers? \n"
"! No argument here. \n\n"
"RWC: Oh no! The professor will hit me! \n"
"[] But if Zoidberg 'fixes' it… then perhaps gifts! \n\n"
"I was all of history's great robot actors - Acting Unit 0. 8; Thespomat; David Duchovny!\n\n"
"[] Five hours? Aw, man! Couldn't you just get me the death penalty?\n\n"
"When I was first asked to make a film about my nephew, Hubert Farnsworth, I thought \"Why should I?\" Then later, Leela made the film. But if I did make it, you can bet there would have been more topless women on motorcycles. Roll film! Um, is this the boring, peaceful kind of taking to the streets?\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.