#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$"
Local $sString = "https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")