import re
regex = re.compile(r"^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$")
test_str = "https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")