package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^({(?:[^{}]++|(?1))*})$`)
var str = `{ abc }
{ a { bc } }
{ a {{}} }
{ a b cde }{aa}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}