$re = '/^({(?:[^{}]++|(?1))*})$/m';
$str = '{ abc }
{ a { bc } }
{ a {{}} }
{ a b cde }{aa}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);