$re = '/(?<=<)[0-9]+(?=>)/';
$str = '"\\r\\radmin@Modem -- *<456> \\radmin@Modem -- *<456> "';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);