re = /(?<=<)[0-9]+(?=>)/
str = '"\\r\\radmin@Modem -- *<456> \\radmin@Modem -- *<456> "'
# Print the match result
str.match(re) do |match|
puts match.to_s
end