#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+\d{2}\s*(\(\d{2}\))|(\(\d{2}\)))?\s*\d{4,5}\-?\d{4}"
Local $sString = "11111111" & @CRLF & _
"111111111" & @CRLF & _
"(11) 11111111" & @CRLF & _
"(11) 111111111" & @CRLF & _
"+11 (11) 11111111" & @CRLF & _
"+11 (11) 111111111" & @CRLF & _
"" & @CRLF & _
"1111-1111" & @CRLF & _
"11111-1111" & @CRLF & _
"(11) 1111-1111" & @CRLF & _
"(11) 11111-1111" & @CRLF & _
"+11 (11) 1111-1111" & @CRLF & _
"+11 (11) 11111-1111" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")