package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\+\d{2}\s*(\(\d{2}\))|(\(\d{2}\)))?\s*\d{4,5}\-?\d{4}`)
var str = `11111111
111111111
(11) 11111111
(11) 111111111
+11 (11) 11111111
+11 (11) 111111111
1111-1111
11111-1111
(11) 1111-1111
(11) 11111-1111
+11 (11) 1111-1111
+11 (11) 11111-1111
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}