using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( of (?:(?!\band\b)[A-Za-z ])+)?";
string input = @" of New Mexico and Mrs Smith.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}