const regex = new RegExp('( of (?:(?!\\band\\b)[A-Za-z ])+)?', '')
const str = ` of New Mexico and Mrs Smith.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}