#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Total Payout:\s+\K\D+"
Local $sString = "Confirmation code: " & @CRLF & _
"" & @CRLF & _
"Payout: " & @CRLF & _
"€66 x 7 Nights: €461" & @CRLF & _
"Airbnb Service Fee: -€17" & @CRLF & _
"Total Payout: €444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")