import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Total Payout:)\\s+(.*\\d+)";
final String string = "Confirmation code: \n\n"
+ "Payout: \n"
+ "€66 x 7 Nights: €461\n"
+ "Airbnb Service Fee: -€17\n"
+ "Total Payout: €444";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}