re = /(?<=Total Payout:)\s+(.*\d+)/
str = 'Confirmation code:
Payout:
€66 x 7 Nights: €461
Airbnb Service Fee: -€17
Total Payout: €444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end