package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[01][0-9]|2[0-3]):[0-5][0-9]\b`)
var str = `00:00
12:20
23:59
34:45
100:234
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}