# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)
(?<curly> \{ \g<content>*? \} )
(?<square> \[ \g<content>*? \] )
(?<nested> \g<curly> | \g<square> )
(?<content> [^{}\[\]]++ | \g<nested> )
)
\g<nested>
"""
test_str = ("EVENLY BALANCED curly braces\n\n"
"{{{}}}\n"
"{ test1 { test2 { test3 { test4 } } } }\n\n"
"UNEVENLY BALANCED curly braces\n"
"{{{{}}} ] <-- this is needed, otherwise this line balances with the line below :)\n"
"{ test1 { test2 { test3 { test4 } } } } }\n\n"
"MULTI-LINE EVENLY BALANCED curly braces\n"
"{\n"
"}\n\n"
"MULTI-LINE UNEVENLY BALANCED curly braces\n"
"{{\n"
"}\n\n\n"
"EVENLY BALANCED square braces\n"
"[ test1 [ test2 [ test3 [ test4 ] ] ] ]\n\n"
"EVENLY BALANCED square and curly braces\n"
"{ test1 [ test2 { test3 [ test4 ] } ] }\n\n"
"UNEVENLY BALANCED square and curly braces\n"
"{ test1 [ test2 { test3 [ test4 ] } } ]\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.