using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*_(\d+)_.*$";
string input = @"SYND_YAHOO_7BEST_RANKADDITIONS_268_2357425";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}